The newer versions of RabbitMQ from have issues with older version of DotNet and Visual Studio 2013.

I picked the highest release before 4.0 and at least the NuGet package installed.

Install-Package RabbitMQ.Client -Version 3.6.9

Trying to install anything after 4.0 will give the following errors:

PM> Install-Package RabbitMQ.Client -Version 5.0.1
Installing ‘RabbitMQ.Client 5.0.1’.
Successfully installed ‘RabbitMQ.Client 5.0.1’.
Adding ‘RabbitMQ.Client 5.0.1’ to RabbitMQConsoleTester.
Uninstalling ‘RabbitMQ.Client 5.0.1’.
Successfully uninstalled ‘RabbitMQ.Client 5.0.1’.
Install failed. Rolling back…
Install-Package : Could not install package ‘RabbitMQ.Client 5.0.1’. You are trying to install this package into a project that targets
‘.NETFramework,Version=v4.5’, but the package does not contain any assembly references or content files that are compatible with that framework. For more
information, contact the package author.
At line:1 char:1
+ Install-Package RabbitMQ.Client -Version 5.0.1
+ ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
+ CategoryInfo : NotSpecified: (:) [Install-Package], InvalidOperationException
+ FullyQualifiedErrorId : NuGetCmdletUnhandledException,NuGet.PowerShell.Commands.InstallPackageCommand


Filed under: C#