No, BizTalk 2013 (nor prior release of BizTalk) do NOT support IBM WebSphere MQ 8.0. We confirmed this with a ticket to Microsoft.

What is confusing is the following on Microsoft page: http://msdn.microsoft.com/en-us/library/jj248684%28v=bts.80%29.aspx#BKMK_MQSeries

According to current information, supported IBM WebSphere MQ versions in Microsoft BizTalk Server 2013 and 2013 R2 :

    IBM WebSphere MQ 6.0.2.12 and later
    IBM WebSphere MQ 7.0.1.9 and later
    IBM WebSphere MQ 7.1.0.5 and later
    IBM WebSphere MQ 7.5.0.3 and later

Further information: Install MQSeries Prerequisites

“And later” apparently means only in the same 7.x series. Apparently WebSphere 8.0 added 64-bit support, and BizTalk has not yet been updated to use it. BizTalk will try to work, but apparently it has an issue not being able to load some IBM WebSphere .DLL that was moved to a different folder path.